Print Topic

Computer Q&A Board  /  Reader's Tips  /  Help!
Posted by: 33 (Guest), February 26th, 2014, 12:29pm
I was looking at the following message: "STOP: c0000218 {Registry File Failure} The registry cannot load the hive (file): \systemroot\system32\config\SECURITY or its log or alternate. It is corrupt, absent or not writable"

I am now at the dos command prompt, but when I try to run chkdsk, it tells me I must use "Scandisk".  When I try that prompt, with various switches, I get "bad command".

This is on an old eMachine, with Windows XP Hm Edit SP3.

Initial start up stalls on a screen that says among other things: IDE Channel ). Master Disk HDD S.M.A.R.T. capability . . . disabled.

Everything was running fine yesterday - though I did remove some old programs - correctly, and then ran A1Click Ultra PC Cleaner to make sure everything was cleaned up. Then I shut her down for the evening and received this surprise this AM

I do not have access to the internet with that PC. Any suggestions...?  Hope, hope...!
Posted by: 112 (Guest), February 27th, 2014, 10:16pm; Reply: 1
   It sounds like the security file of the registry is messed up.  That is not something that A1Click would have messed with.  RegVac or WinRescue might have, if you used one of those.
   Doesn't eMachine have Angel Recovery on it?  I am thinking that it does.  If it does and you tried to do something with the registry, like restore it or pack it, Angel Recovery will crash your computer in that way.
   If you can find a different security file in one of the subdirectories and copy it into that location, C:\Windows\system32\config\, it should fix the problem.  You might want to rename the first security file first, just in case you want it back later.
   WinRescue and RegVac should have put a backup in the Windows directory or one of the subdirectories, if you had used them.
   I hope that helps.
Posted by: Philz (Guest), February 27th, 2014, 11:19pm; Reply: 2
It does have Angel Recovery, and once that was initiated I couldn't get past it. I ended up using an recovery disc I had that enabled me to create a partition to try to be sure to save everything. Even though I had a back up partition in existence on my system, I couldn't access that either.  Once I got everything backed up again - just in case, i then got into "dos" and using that recovery disc was able to repair the registry and bios, which got me going again. In the process, it looks like I cleaned out a lot of junk, and it's actually running better than it has in awhile - though I haven't shut her down for the evening yet...

By the way I mentioned that I had used A1Click - but did not mean to suggest that program had anything to do with the problems. I love A1Click! But I was doing some preventative maintenance on my machine, then ran A1 and all seem dwell, until I tried to fire her up the next day.  

A1 works great - I have purchased copies for my wife and daughter's machines, too.

Thank you for getting back to me.
Posted by: 112 (Guest), February 28th, 2014, 10:00am; Reply: 3
   For some reason when Angel Recovery detects that the registry files have been changed (as in putting a different registry file where the old one was), it ruins the security file, and then you have the problem that you had.
   If you start your computer in DOS and make a copy of that security file (call it security.001 or something like that), it will be easier to recover from the next crash.  After a crash you will just need to start in DOS and rename the security file to something else and rename the security.001 to security.
   Thank you for the kind words and your purchases.
Print page generated: October 18th, 2021, 3:22pm